Apollo Client (CLI) behind Corporate Proxy

I’m trying to run an open-source application which uses the apollo client (via CLI) in my development infrastructure in the office. This infrastructure runs behind our corporate proxy, so every request to the outside internet has to go through the proxy.

When the app starts, it starts the apollo client which loads an external schema from the internet. This works well on my private computer, but in the office, I get a timeout while trying to load the schema, so I’m sure the (not) proxy-connection is the problem.

I’ve looked through the docs of the apollo client but could’nt find anything about proxy settings. Using environment variables in Linux doesn’t work. Do I have any chance to tell the apollo client to use our corporate proxy for loading the external schema?

Ok, I found my mistake. Although Apollo Client is using global-agent, my HTTP_PROXY-Variable mustn’t start with GLOBAL_AGENT_ Prefix. Without the Prefix, everything works fine.