Lift-off-V Changing length to durationInSeconds results in null values


I was attempting to change length to durationInSeconds in the client following the instructions in this module:

and I went through my client code and changed length to durationInSeconds but running it locally I see values of null where the durationInSeconds should be. Commit

I’m curious if anyone else in the community was also having this issue.

Hey @jpvajda ! Thanks for the info and linking to your repo!

After some digging I found that your server code had an error in the resolvers.js file.

It should say return length; instead or just length; in that line. The property wasn’t getting returned, which was why you were getting null as a value.

Hope that helps, let me know if you run into any other errors. And hope you enjoyed the Lift-off series :slight_smile:

Thanks for the reply @MichelleMabuyo I appreciate it and I love this lift-off series, it’s been one of the best learning tracks I’ve ever done to learn something new.

I did make this change, but didn’t see any changes to the null issue, > commit

I’ll continue to debug the problem, as I think it must be something I just missed in the client code to change the deprecated field.

Hello @jpvajda.
Glad that you’re liking the series so far!
I tried running both of your forks locally (client and server, with client querying local server) and with the latest change you added to your resolvers, everything seems to work fine.
Maybe the latest changes of your server repo weren’t successfully deployed to your heroku app?

Thanks @Raph I did go ahead and deploy my updates on heroku and it’s working now, though I still was seeing null values locally when running the server and client so I ran npm rebuild and npm cache clean and that did the trick. Thanks for the additional support!