Why was _FieldSet changed to FieldSet?

The federation spec had _FieldSet which was in line with all the other types it defines (starts with underscore).

This commit is responsible. but I’m not sure I see any reason it was done.

Just make it hard to implement a spec if it keeps changing!

Are any more changes in type names planned, or maybe was this an unintentional change?

Here @key has _FieldSet ?