Apollo Client version 2 still compatible with React 18?

Hi Guys,

My project is using Apollo-Client version 2 and I have upgraded my React to version 18 and would like to know if Apollo Client 2 still works well with React 18 or need to upgrade to version 3.

Thank you!

Here to ask the same question. Can someone please respond? Thankyou