Error "Subgraph errors redacted" authorization header token


we use apollo studio to test our Endpoints to strapi. We secured the Strapi endpoint with an access token. I followed the docs on how to add a token into the header, but i don’t get any responses.

what i did so far:

  • the token is right. Tested in postman and it is working fine.
  • set the token as Environment variables in the Personal Settings
  • added the token in the header

Thanks for help.


Are you using Apollo Router or Apollo/Gateway & server?

In either case are you passing the Authorization header from the supergraph down to your subgraph?

hi mikeq,
thanks for your reply. I’m new to apollo, so please apologise my maybe obvious questions.

what do you mean by this? Where can i set the header in the supergraph? I don’t see any subgraphs in the settings, so i havn’t set up any.


Is this an out the box GraphQL API or one you have created?

If it is an out the box API I’d try making calls to it in Postman (you can do GraphQL queries in that) that will help figure out if it is an Apollo Sandbox issue or their API. (or you could even use Curl).

I would also initially bring back as few fields as possible, maybe just {stories { data { attributes { category } } } }.

Maybe link to the documentation of the API config settings.


thanks for the fast reply.
It is an out of the box API and i already tested that in Postman and it is working fine. So thats why i came across this forum, bc it seems to be an Apollo Sandbox issue or i’m just missing a setting.


Not much help to you, but I have similar for my APIs and it works fine. Only thing I can think of is it is a CORS issue.

thanks for your help. I know why it didn’t work, you need to send the authorization when you create the subgraph…at least when you use the strapi api

Okay, I am getting the same error and I would like to fix it because Postman is limited on the api calls