Help for Lift-off part 5, Deploy Branch

Hi guys, I tried to Deploying Apollo server, and I make all tasks, deploy branch, but for some reason, I have this Error.

Application error

The log is

2021-11-03T22:03:18.932304+00:00 app[web.1]: npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

2021-11-03T22:03:18.935225+00:00 app[web.1]:

2021-11-03T22:03:18.935295+00:00 app[web.1]: npm ERR! A complete log of this run can be found in:

2021-11-03T22:03:18.935331+00:00 app[web.1]: npm ERR! /app/.npm/_logs/2021-11-03T22_03_18_932Z-debug.log

2021-11-03T22:03:19.056438+00:00 heroku[web.1]: Process exited with status 1

2021-11-03T22:03:19.219663+00:00 heroku[web.1]: State changed from starting to crashed

2021-11-03T22:03:31.268548+00:00 heroku[router]: at=error code=H10 desc=“App crashed” method=GET path="/" host=server-catstronauts-hg.herokuapp.com request_id=1b99127e-b196-43c0-9a24-a93a6beb5e67 fwd=“45.236.29.99” dyno= connect= service= status=503 bytes= protocol=https

If you can help me I really appreciate it.

Ups!!! I fixed :wink:

In the index.js file, I did still have my configuration to apollo studio

require(“dotenv”).config();

Delete this line and now work

I read carefully the course and find this, Heroku sets the NODE_ENV environment variable to production.

Thanks anyway guys, I hope this post helps someone

Glad you’ve got it working @hendridg! And congrats on completing the Lift-off series :smiley:

I also had this problem. First I added “engines” in the package.json file cause I thought it will solve the problem, but it didn’t.
example: “engines”:{“node”: “v14.17.5”, “npm”: “7.24.2”}

then, I tried to remove the author’s name (which is a huge problem on my part because I am not the original Author of the app. It’s kind of piracy for me, not putting the real author.).

But the deployment worked after I removed the original author “Raphael Terrier @R4ph-t” 's name in the package.json file. I didn’t add my name so it’s authorless, sorry Raphael.

(I don’t know if this problem was heroku’s end or my github’s security’s end). Just sharing my thoughts.

Thanks for sharing @jobdecrypt ! Curious if this was for both the client and server repos where you made this change?