Issue with lift-off-1 Odyssey

Hi there,

On my localhost, I’ve got an error in the last step of the project:
ERROR: Unexpected token '<', "<!DOCTYPE "... is not valid JSON
Do you know where this error can come from? I tried to investigate but I cannot figure it out ; I even tried to copy-paste everything from the final folder but got the same error.

Thank you

Hey @kurichu!

Is your server working correctly when querying from Apollo Sandbox?

Which lesson are you following along with?

Hi Michelle,
thank you for your reply.

Yes, my server is working correctly when querying from Apollo.
I’ve absolutely no idea where the issue comes from :frowning:

Hi Michelle,

Sorry I forgot to mention that I’m following this course:

Thank you

Hi @MichelleMabuyo

Just to let you know, it’s finally working.
The problem was that I set the uri to a localhost:3000 instead of localhost:4000. I was also killing the backend server when running the client on my local, so both weren’t running at the same time.

Thank you for your help.

1 Like

Glad to hear you caught the issue @kurichu!