ApolloServer 3 caching - Diminished performance when Redis is down

I have Apollo Server set up with a Keyv Redis cache and I’d like to fallback on the default, non-caching behavior when Redis is down. Functionally, I am achieving this, but I am seeing significantly diminished performance. I am able to improve the performance by providing the Keyv constructor with ioredis optionals:

    maxLoadingRetryTime: 100,
    maxRetriesPerRequest: 0

However, even with these provided, I observe that requests take seconds (~10x) longer. This is true even for operations with maxAge set to 0. The documentation states these should not be cached, so I’d assume these should not be affected by the state of the Redis connection at all.

Is there some optional or cache configuration that I am missing? Keep in mind that this is using version 3 and I am not currently in a position to upgrade.

I have found that these settings force all requests to wait for the application to attempt reconnection to the Redis server maxRetriesPerRequest times. This is unavoidable for the requests that are cached, but I would like to skip this process for requests with responses that have maxAge set to 0, as these should never be dependent on the cache anyway.