Lift-Off II: Resolvers - Error with datasource-rest

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: catstronauts-server@1.0.0
npm ERR! Found: graphql@15.8.0
npm ERR! node_modules/graphql
npm ERR!   graphql@"^15.5.1" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer graphql@"^16.5.0" from @apollo/datasource-rest@6.0.0
npm ERR! node_modules/@apollo/datasource-rest
npm ERR!   @apollo/datasource-rest@"*" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

Running this command npm install @apollo/datasource-rest but getting the above error

Hi there @nkekre ! I’m happy to help you troubleshoot this error.

Had you run npm install in the repository’s server directory prior to running npm install @apollo/datasource-rest?

It looks like the main issue here is that the @apollo/datasource-rest package requires that the graphql package have a version of 16.5.0 or higher. When you open up the server/package.json file, can you tell me what version of graphql you have listed there?

I believe that if we update the version to the below, and try running npm install again, we might be able to get around this problem!

"graphql": "^16.6.0",

Looking forward to hearing back from you!