My entire team shares a codegen npm command. When I run it, I get different results

My team uses this npm command to generate schemas:

npx apollo@2.33.4 client:codegen --target='typescript' --includes='./src/**/*.+(tsx|ts)' 

I have made sure I have apollo 2.33.4 (exactly) installed and have the same version as my teammates; however, when I run a codegen, almost the entire contents of the schema file has diffs – some are from misc changes of description: null to description: "" and removing "specifiedByUrl"/"deprecationReason"; while others changes are complete reordering of different type definitions.

when everyone else on my team runs it, they don’t see any diffs. how can I stop codegen from acting differently on my machine?

The changes you’re describing sound like differences between various graphql versions (which, as I recall, has made changes like this over the years).

Are you all using the same version of graphql?

Yes! Interesting thought - but we are all using the same graphql versions.

I actually just downgraded my node version from 15 to 14; and that seems to have done the trick so far. Thanks for your response

Glad that did the trick!