Odyssey-Voyager I Section 8: Cannot reach server

Cannot reach my server on any browser with Explorer. The endpoint diagnosis gives this. Literally just following the tutorials step by step…

How do I enable introspection or allow my superGraph to be queried?

Finished the course with this product? Everything update my supergraph correctly just can’t actually connect to it

I’m having that exact same error. Re-installed everything, started from scratch 2 times, I did the usual cleanup and start over routines and still unable to end the unit.

It surprises me that it looks like not many people had this issue (or not many have done this tutorial?). If anyone have a hint, please chime in!

Hello @GreenJ84 and @scarabetta!

Thanks for bringing this to our attention. I ran through the course again and was able to get it working successfully (without needing to turn on introspection or any extra steps). Here are a few things I’d like to check:

  1. What browser are you using? For best results, we recommend using Studio with Chrome or Firefox. Other browsers have content policies that may restrict connections to local endpoints without implementing SSL.

  2. When you created a graph in Lesson 6: Publishing the subgraphs with Rover, there are alternate steps provided, depending on when you created your account and what plan you’re on. Can you confirm that you were able to create a Classic Graph or Graph? (See screenshot below for what this looks like in the course)

  1. When you run the router in your local terminal, do you see a message that says something like INFO GraphQL endpoint exposed at 🚀?

  2. Are both subgraphs running successfully? (Ie have you ran npm start in the subgraph-locations and subgraph-reviews folders?)

Let me know, I hope we’re able to troubleshoot what’s going on!

  1. I am working with Brave browser but have tried Chrome and Safari with the same errored results.

  2. I am looking into the different creation steps now as I did not originally see that going through the course and it may be part of the problem. Will let you know about it soon.

  3. My router starts and it gives the success message. It is only the ability to query the router that is non-functional. Both from the app and from studio.

  4. Both of the subgraphs successfully run and can be queried from all browsers with no problems.

The different creation steps did not lead anywhere. However, I did find out how to turn on introspection manually and now have different errors.

When diagnosing the endpoint (What studio says to do with the error message) I get this new error as well.

I have solve the problem. The issue in general was that introspection was not allowed of the bat. Adding (dots represent indentation)

…introspection: true
…all: true

to the config file. Introspection allows my to connect to the router via explorer and the app. The error reporting allowed me to figure out what was going wrong (an extra ‘s’ in one of the revolver functions).

Both would definitely be beneficial to reference in Voyager I to help users out.

Hi Michelle, thanks for coming to the rescue!!

All the points you mentioned were checked, and I was able to narrow down the issue to a connection between Apollo Router and the two servers (location and reviews).

After trying different options to install Router (PS, WSL) , I downloaded the .gz and installed in its own folder. Apparently, it worked (I hope I can reproduce the success…!)

Thanks for the help, I’ll continue the tutorial

Thanks for including your solution, @GreenJ84 ! I’m surprised about the introspection needing to be enabled - I’ll double check with my team to see if anyone else ran into the same issue.

include_subgraph_errors is a good one to enable for troubleshooting the actual error though - we’ll see where we can add that tidbit in the course! Thank you again!

Hey @scarabetta, I’m glad you’re able to continue! Hmm, what machine are you using? I see the docs specifies that the curl approach is for Linux, OSX, WSL. We can definitely be clearer about this requirement in the lesson itself!

I’m using a Windows 11 machine. Everything went well when installing with npm. I’ve tried and re-tried so many times that I can recall the exact sequence, but when I tried to install Rover first and Router later, I had a mix of Power Shell and WSL windows. I had to fiddle a little with PS execution policies, until finally it was able to connect with the Javascript servers.


1 Like