Unable to override the url of a mocked subgraph in Apollo Workbench

I was testing Workbench graphs locally by following Testing Workbench graphs locally - Federation - Apollo GraphQL Docs. I followed the instructions in the “Using non-mocked subgraphs” section and changed the url of a subgraph to point to a local graphql server, e.g. from a default localhost:4004 to localhost:3333/graphql that serves real data. However, when I restarted the supergraph, the changed url in the subgraph settings went back to the default. Any ideas?