Lift-Off I Setup Client Error - eslint version incompatibility?

Hey there, I’m having an issue with eslint and running npm start in the client directory. While in /client directory in terminal, after I’ve done the npm install, I run npm start and get the following error:

catstronauts-client@1.0.0 start
react-scripts start

There might be a problem with the project dependency tree.
It is likely not a bug in Create React App, but something you need to fix locally.

The react-scripts package provided by Create React App requires a dependency:

“eslint”: “^7.11.0”

Don’t try to install it manually: your package manager does it automatically.
However, a different version of eslint was detected higher up in the tree:

/Users/jack/node_modules/eslint (version: 8.4.0)

Manually installing incompatible versions is known to cause hard-to-debug issues.

If you would prefer to ignore this check, add SKIP_PREFLIGHT_CHECK=true to an .env file in your project.
That will permanently disable this message but you might encounter other issues.

To fix the dependency tree, try following the steps below in the exact order:

  1. Delete package-lock.json (not package.json!) and/or yarn.lock in your project folder.
  2. Delete node_modules in your project folder.
  3. Remove “eslint” from dependencies and/or devDependencies in the package.json file in your project folder.
  4. Run npm install or yarn, depending on the package manager you use.

In most cases, this should be enough to fix the problem.
If this has not helped, there are a few other things you can try:

  1. If you used npm, install yarn ( and repeat the above steps with it instead.
    This may help because npm has known issues with package hoisting which may get resolved in future versions.

  2. Check if /Users/jack/node_modules/eslint is outside your project directory.
    For example, you might have accidentally installed something in your home folder.

  3. Try running npm ls eslint in your project folder.
    This will tell you which other package (apart from the expected react-scripts) installed eslint.

If nothing else helps, add SKIP_PREFLIGHT_CHECK=true to an .env file in your project.
That would permanently disable this preflight check in case you want to proceed anyway.

P.S. We know this message is long but please read the steps above :slight_smile: We hope you find them helpful!

/////////////////////////////////////////// end of the error

So I’ve tried following steps 1-7 without avail, but have not added the SKIP PREFLIGHT CHECK, because I’m not sure what effect it will have on the functionality of the app.

Any advice of what actions I could take next to solve this issue?

I just added a .env file as well, with SKIP_PREFLIGHT_CHECK=true

but still encountering the issue

Ok I moved the .env file to client directory, instead of the root. Now the server has started correctly. But I would still be interested if anyone knows a better solution, feel like I’m just bypassing the actual error.

Hi there @1speedgo !

Hmm it looks like your version of eslint that was installed in a higher-up directory (perhaps globally?) isn’t compatible with create-react-app yet. I found this thread with a similar issue as yourself: eslint v8.0.0 giving issues when trying to start/build react app · Discussion #15156 · eslint/eslint · GitHub

Can you try downgrading back to eslint v7?