Odyssey Lift-off I: Basics | FEATURE OVERVIEW AND SETUP

Hello Friends,

I’m new to GraphQL and this community and I hope everybody is doing okay. I’m currently on the very first tutorial and I can’t get the client up and running part working. At this point I have tried a bunch of things to get it to work but no luck. I follow the steps on the repo → GitHub - apollographql/odyssey-lift-off-part1 and I still had no luck.

when I run npm start inside the client folder I still get the error below. If anybody could help me that would be highly appreciated because I’m out of ideas at this point.

catstronauts-client@1.0.0 start
react-scripts start
sh: react-scripts: command not found

Hey @ronnypdev ! Sorry to hear you’re running into issues, I’m hoping we can troubleshoot this together!

Usually when I run into this error, it’s because I forgot to run npm install first. Can you try running npm install, then run npm start again?

If that still doesn’t work, were there any errors in the output of the npm install?

Can you also confirm what version of node you’re using? You can find out by running node --version.

Hi @MichelleMabuyo

my node version is this one → v19.5.0

for npm install this is what i. got

npm WARN deprecated fsevents@1.2.4: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.

up to date, audited 2135 packages in 11s

137 packages are looking for funding
run npm fund for details

80 vulnerabilities (13 low, 16 moderate, 46 high, 5 critical)

To address issues that do not require attention, run:
npm audit fix

To address all issues (including breaking changes), run:
npm audit fix --force

Run npm audit for details.

for npm start, this is what I got

catstronauts-client@1.0.0 start
react-scripts start

sh: react-scripts: command not found

Hey there @ronnypdev ! Thanks for the additional information. I tried running the app on that Node version and was able to get it started up – so we’ve probably got a different issue on our hands!

It looks like we might be having some trouble with the fsevents package. I did a bit of research and this appears to be something that can get pulled in as a dependency and can cause a little bit of confusion. To get closer to the solution, could you jump into the project’s package-lock.json file that is generated after running npm install, and let us know what version number is installed for fsevents? On my side, for example I see the following.

"optionalDependencies": {
    "fsevents": "~2.3.2"

A version above 1.2.4 looks like it might satisfy the error, so I wonder if there’s something holding it back from reaching the 2.3.2 version I see in my project.

First I’m curious to see if your package-lock.json file is picking up on the same version that I see in my repo locally, but here are some other avenues we can pursue if that doesn’t yield anything:

  • Based on this Stack Overflow thread one other solution we could try might be to run the install command with the --no-optional flag.

  • We can also try changing node versions and running the install again to see if that helps. If you have a tool like nvm or volta to manage which version of Node you’re running, we could try downgrading to a version like v16.13.0 or even earlier to try and isolate the problem you’re seeing.


Hey @lizhennessy thank you so much for your kind response. I tried everything you suggested and still not working. I check that the fsevents is 2.32 and it is. I also switched the node version per your suggestion and still same problem. I honeslty dont know what do at this point.

I’m so sorry this has been such a sticky and persistent problem @ronnypdev ! Michelle, on my team, was able to recreate the error you’ve been seeing, but only when the node_modules folder was missing from her client directory. When that error pops up for you, do you see the node_modules folder in client? (And to confirm - when you’re running npm install, it’s within that client directory?) Thank you! Still hoping that we can get this solved for you. :crossed_fingers:

hi @lizhennessy

thank you for the reply. I just had to use another computer and it worked. fine in the other computer.

Thanks for the update @ronnypdev ! I’m disappointed we weren’t able to pinpoint the problem and identify a fix for you - but certainly glad that you found a way around it. Please do let us know if you run into any other issues as you work through the courses on Odyssey!