Odyssey Lift Off pt 2

Ugh! I am now getting errors - I cloned part 2 into VS Code ran npm install && npm start… Server side runs, but not client. In Chrome Dev tools error:

Failed to load resource: net::ERR_CONNECTION_REFUSED :4000:1

POST http://localhost:4000/ net::ERR_CONNECTION_REFUSED createHttpLink.ts:146

Not sure why I cannot connect. I have restarted both chrome, vs code…

Please help

Hello @JJLindsey! Hmm, so the server should be running on port 4000, but from that error, it looks like the client is not able to connect to it.

First, let’s make sure the server is running! When you run npm start in the server folder, what do you see in the console? Can you run a test query in Studio? You can reference this Lift-off I lesson if you need a refresher on how to do that!

If you’re able to run a test query in Studio then that means the server is running and working! Next step would be to start the client app again, making sure to do this in a new terminal window. So you’ll have 2 terminal windows open, one for server and one for client.

When you run npm start in the client window, do you still get the same error?

I was not using 2 sep terminal windows. Query working in Studio

Ahh I see! We’ll need to use 2 separate terminal windows since we want to keep the server running AND the client running as well. The query working in Studio is a good sign that the server is up and running! Hopefully running the client app in a separate terminal window works for you!

Hello @MichelleMabuyo. I’m having the same issue as @JJLindsey. I read your last reply, but I’m not sure what your thoughts were.

@JJLindsey My terminal message also noted that the development server connection was refused and provided a link to check the React documentation here environment variables for react development.

I also posted asking for help. @MichelleMabuyo any thoughts would be appreciated.

Kind regards,


@JJLindsey @JJLindsey , @brainkim provided these options to solve the development server issues for the React Client in the Odyssey tutorial.

It worked in my situation. Here’s the link:

Odyssey Tutorial Dev Server for React Client

Kind regards,



@deen @MichelleMabuyo

hey, just saw your post. I just forgot to open a second terminal window. Deen, glad to see you got it working.