Cannot enable Introspection

I have embedded apollo-server-micro in a Next.js application and desire to have Introspection enabled.

I create the server with introspection: true however, despite my best attempts, I cannot get the built and deployed application to allow introspection.

I am deploying this to EKS on AWS, I’ve set NODE_ENV=development both in the Dockerfile and the EKS deployment configs. Despite my best attempts, something keeps disabling introspection.

Any idea what could be doing this? Other npm modules are responding to NODE_ENV, so I know that is set correctly.

It definitely sounds like your NODE_ENV is being seen as production somewhere / somehow, but it also sounds like you’ve verified that in other ways. Maybe try explicitly setting the introspection property of the ApolloServer constructor to true, to see if that helps?

I am explicitly setting introspection to true, it’s still not working.

it’s unfortunate that apollo gives precedence to NODE_ENV and not introspection:true.

Is there any way to force this behavior?