The Explorer Isn't Available Locally


I’m following the Quickstart, and when I start the router, my localhost:4000 page only gives me the option to send a POST request:


Here’s the output from starting the router, which looks OK:

2022-11-09T19:34:35.699798Z  INFO Apollo Router v1.2.1 // (c) Apollo Graph, Inc. // Licensed as ELv2 (
2022-11-09T19:34:35.701522Z  INFO Anonymous usage data is gathered to inform Apollo product development.  See for more info.
2022-11-09T19:34:38.683986Z  INFO Apollo Studio usage reporting is enabled. See for details
2022-11-09T19:34:38.685474Z  INFO creating apollo exporter spaceport_endpoint=
2022-11-09T19:34:38.726337Z  INFO creating apollo exporter spaceport_endpoint=
2022-11-09T19:34:40.862328Z  INFO healthcheck endpoint exposed at
2022-11-09T19:34:40.868799Z  INFO GraphQL endpoint exposed at 🚀

Any thoughts as to what I’m missing?


Hello :wave:

I believe sandbox might be disabled by default. See Configuring the Apollo Router - Apollo GraphQL Docs for details.

Thank you Derek! That did the trick.